The Wiki has moved to new hardware, and the old server died.

Welcome to the Slackware Documentation Project

This is an old revision of the document!

Discussion about DisplayLink support in Slackware

Update December 11, 2018:

DisplayLink package version 4.4.24 with Slackware64-current (kernel version 4.19.8) shows screen with lines of different colors and second monitor does not work with x-org-server packages on 1.20.3 (xorg-server, x-org-server-xephyr, xorg-server-xnext and xorg-server-xvfb)

The package downloaded from DisplayLink did not install this time. I had to repackage the packages using the ones from SBo and evdi packages for 1.5.1:

with a small modification for the displaylink.SlackBuild

Downgrading all x-org-server packages to 1.19.6 did not work at first. A workaround was to create a script to enable HDMI (without any HDMI monitor plugged in) and then enabling the two monitors, which then worked flawlessly

Contents of

xrandr --listproviders --setprovideroutputsource 1 0
xrandr --output DVI-I-1-1 --auto
xrandr --output DVI-I-1-1 --pos 0x0 --output HDMI1 --pos 1920x0 --output eDP1 --pos 3840x312

Contents of

xrandr --listproviders --setprovideroutputsource 1 0 --setprovideroutputsource 2 0
xrandr --output DVI-I-1-1 --auto --output DVI-I-2-2 --auto
xrandr --output DVI-I-1-1 --pos 0x0 --output DVI-I-2-2 --pos 1920x0 --output eDP-1 --pos 3840x312

I tried both of them, and rebooted after each change. The one mentioning intel required to be Intel (capital I). None of them yielded positive results. In each case, once trying to activate the screen using xrandr I was logged out and kicked back to the gdm login screen

The docking station I use is this one:

It uses the DisplayLink chipset. I have one at work. At home I use a regular HDMI cable and an external monitor, which work, even with xorg-server 1.20.0


F. Bobbio C. (a.k.a. Akileo)

Akileo, that page you link to contains two workarounds that do not require downgrading xorg-server. Have you tried them? What was the result?
Eric Hameleers 2018/07/05 17:55 (UTC)

Greetings, fellow Slackers, I am running Slackware64-current with Plasma5. Has anyone encountered issues with xorg-server 1.20.0 while running DisplayLink? I have the same issues as listed here:

I had to downgrade to xorg-server-1.19.6 with x-org-server-xephyr, xorg-server-xnext and xorg-server-xvfb also on the same version

I had the same issues with Slackware64-current with KDE 4, by the way. Any pointers/solutions/comments on how to fix the issue, if at all possible, while running xorg-server 1.20.0 would be more than welcome


F. Bobbio C. (a.k.a. Akileo)

In Other Languages
Translations of this page?:
QR Code
QR Code talk:howtos:hardware:displaylink (generated for current page)