Welcome to the Slackware Documentation Project

This is an old revision of the document!


Discussion about DisplayLink support in Slackware

Greetings, fellow Slackers, I am running Slackware64-current with Plasma5. Has anyone encountered issues with xorg-server 1.20.0 while running DisplayLink? I have the same issues as listed here: https://support.displaylink.com/knowledgebase/articles/1181623-displaylink-ubuntu-driver-after-recent-x-upgrades

I had to downgrade to xorg-server-1.19.6 with x-org-server-xephyr, xorg-server-xnext and xorg-server-xvfb also on the same version

I had the same issues with Slackware64-current with KDE 4, by the way. Any pointers/solutions/comments on how to fix the issue, if at all possible, while running xorg-server 1.20.0 would be more than welcome

Regards,

F. Bobbio C. (a.k.a. Akileo)

Akileo, that page you link to contains two workarounds that do not require downgrading xorg-server. Have you tried them? What was the result?
Eric Hameleers 2018/07/05 17:55 (UTC)

I tried both of them, and rebooted after each change. The one mentioning intel required to be Intel (capital I). None of them yielded positive results. In each case, once trying to activate the screen using xrandr I was logged out and kicked back to the gdm login screen

The docking station I use is this one: https://www.amazon.com/Lenovo-ThinkPad-Docking-Station-0A33970/dp/B008ABKADI

It uses the DisplayLink chipset. I have one at work. At home I use a regular HDMI cable and an external monitor, which work, even with xorg-server 1.20.0


In Other Languages
Translations of this page?:
QR Code
QR Code talk:howtos:hardware:displaylink (generated for current page)