Welcome to the Slackware Documentation Project

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Next revision
Previous revision
talk:howtos:hardware:displaylink [2017/07/31 20:42 (UTC)]
alienbob created
talk:howtos:hardware:displaylink [2019/02/26 19:52 (UTC)] (current)
23.192.124.117
Line 1: Line 1:
 ====== Discussion about DisplayLink support in Slackware ====== ====== Discussion about DisplayLink support in Slackware ======
 +Update February 26,2019
  
 +DisplayLink package version 5.1.26 with Slackware64-current (kernel version 4.19.25) shows screen with lines of different colors and second monitor does not work with x-org-server packages on 1.20.3 (xorg-server,​ x-org-server-xephyr,​ xorg-server-xnext and xorg-server-xvfb)
 +
 +Updated to latest package for DisplayLink: ​ https://​www.displaylink.com/​downloads/​file?​id=1304
 +
 +Updated to latest version of EVDI:  https://​github.com/​DisplayLink/​evdi/​releases/​tag/​v1.6.0
 +
 +Downgraded to x-org-server packages 1.19.6
 +
 +Regards,
 +
 +F. Bobbio C. (a.k.a. Akileo)
 +
 +
 +Update December 11, 2018:
 +
 +DisplayLink package version 4.4.24 with Slackware64-current (kernel version 4.19.8) shows screen with lines of different colors and second monitor does not work with x-org-server packages on 1.20.3 (xorg-server,​ x-org-server-xephyr,​ xorg-server-xnext and xorg-server-xvfb)
 +
 +The package downloaded from DisplayLink did not install this time.  I had to repackage the packages using the ones from SBo and evdi packages for 1.5.1:
 +
 +https://​www.slackbuilds.org/​repository/​14.2/​system/​evdi/​
 +
 +https://​www.slackbuilds.org/​repository/​14.2/​system/​evdi-kernel/​
 +
 +https://​www.slackbuilds.org/​repository/​14.2/​system/​displaylink/​
 +
 +https://​www.displaylink.com/​downloads/​file?​id=1261
 +
 +https://​github.com/​DisplayLink/​evdi/​releases
 +
 +with a small modification for the displaylink.SlackBuild
 +
 +Downgrading all x-org-server packages to 1.19.6 did not work at first. ​ A workaround was to create a script to enable HDMI (without any HDMI monitor plugged in) and then enabling the two monitors, which then worked flawlessly
 +
 +Contents of HDMIMonitors.sh
 +  xrandr --listproviders --setprovideroutputsource 1 0
 +  xrandr --output DVI-I-1-1 --auto
 +  xrandr --output DVI-I-1-1 --pos 0x0 --output HDMI1 --pos 1920x0 --output eDP1 --pos 3840x312
 +
 +Contents of Monitors.sh
 +  xrandr --listproviders --setprovideroutputsource 1 0 --setprovideroutputsource 2 0
 +  xrandr --output DVI-I-1-1 --auto --output DVI-I-2-2 --auto
 +  xrandr --output DVI-I-1-1 --pos 0x0 --output DVI-I-2-2 --pos 1920x0 --output eDP-1 --pos 3840x312
 +
 +
 +I tried both of them, and rebooted after each change. ​ The one mentioning intel required to be Intel (capital I).  None of them yielded positive results. ​ In each case, once trying to activate the screen using xrandr I was logged out and kicked back to the gdm login screen
 +
 +The docking station I use is this one:  https://​www.amazon.com/​Lenovo-ThinkPad-Docking-Station-0A33970/​dp/​B008ABKADI
 +
 +It uses the DisplayLink chipset. ​ I have one at work.  At home I use a regular HDMI cable and an external monitor, which work, even with xorg-server 1.20.0
 +
 +Regards,
 +
 +F. Bobbio C. (a.k.a. Akileo)
 +
 +
 +Akileo, that page you link to contains two workarounds that //do not// require downgrading xorg-server. Have you tried them? What was the result? \\  --- //​[[wiki:​user:​alienbob|Eric Hameleers]] 2018/07/05 17:55 (UTC)//
 +
 +
 +Greetings, fellow Slackers,
 +I am running Slackware64-current with Plasma5. ​ Has anyone encountered issues with xorg-server 1.20.0 while running DisplayLink? ​ I have the same issues as listed here:   ​https://​support.displaylink.com/​knowledgebase/​articles/​1181623-displaylink-ubuntu-driver-after-recent-x-upgrades
 +
 +I had to downgrade to xorg-server-1.19.6 with x-org-server-xephyr,​ xorg-server-xnext and xorg-server-xvfb also on the same version
 +
 +I had the same issues with Slackware64-current with KDE 4, by the way.  Any pointers/​solutions/​comments on how to fix the issue, if at all possible, while running xorg-server 1.20.0 would be more than welcome
 +
 +Regards,
 +
 +F. Bobbio C. (a.k.a. Akileo)

In Other Languages
QR Code
QR Code talk:howtos:hardware:displaylink (generated for current page)