20210628 - Upgrade of php fixed the page rendering issue.

Welcome to the Slackware Documentation Project

Diferencias

Muestra las diferencias entre dos versiones de la página.

Enlace a la vista de comparación

Ambos lados, revisión anterior Revisión previa
Próxima revisión
Revisión previa
es:slackware:package_management_hands_on [2019/08/13 19:34 (UTC)]
slackwarespanol [Construyendo paquetes usando los scripts de SlackBuilds.org]
es:slackware:package_management_hands_on [2019/08/13 19:39 (UTC)] (actual)
slackwarespanol [Sources]
Línea 696: Línea 696:
 </code> </code>
  
-==== Managing package dependencies ====+==== Gestión de dependencias de paquetes ====
  
-Some packages require the presence of other packageseither to build (//build dependencies//) and/or to run (//runtime dependencies//) correctlyIn some casesa required package can depend itself on one or more other packagesand so on.+Algunos paquetes requieren la presencia de otros paquetesya sea para compilar (// dependencias de compilación //) o para ejecutar (// dependencias de tiempo de ejecución //) correctamenteEn algunos casosun paquete requerido puede depender de uno o más paquetesy así sucesivamente.
  
-To take an examplelet's have look at the ''libgnomeprint'' page on SlackBuilds.org. The package description is followed by the following caveat:+Para tomar un ejemploechemos un vistazo la página '' libgnomeprint '' en SlackBuilds.org. La descripción del paquete es seguida por la siguiente advertencia:
  
 <code> <code>
Línea 706: Línea 706:
 </code> </code>
  
-Moreoverevery script tarball contains an ''*.info'' file which states explicitly all the required package dependenciesIf we look at the ''libgnomeprint.info'' filewe'll find a ''REQUIRES'' field:+Ademáscada script tarball contiene un archivo '' * .info '' que establece explícitamente todas las dependencias de paquetes requeridasSi miramos el archivo '' libgnomeprint.info '', encontraremos el campo '' REQUERIMIENTOS '':
  
 <code> <code>
Línea 717: Línea 717:
 </code> </code>
  
-<note>The ''REQUIRES'' field has been introduced with Slackware 14.0.</note>+<note>El campo '' REQUISITOS '' se ha introducido con Slackware 14.0.</note>
  
-This simply means that before we build the ''libgnomeprint'' packagewe have to build and install the ''libgnomecups'' package.+Esto simplemente significa que antes de construir el paquete '' libgnomeprint '', tenemos que construir e instalar el paquete '' libgnomecups ''.
  
-Besides strictly required dependenciesa package can also have some optional dependencies to offer some extra functionalityAs an examplethe Leafpad text editor can be built against the optional ''libgnomeprint'' and ''libgnomeprintui'' dependencies.+Además de las dependencias estrictamente requeridasun paquete también puede tener algunas dependencias opcionales para ofrecer alguna funcionalidad adicionalComo ejemploel editor de texto de Leafpad se puede construir contra las dependencias opcionales '' libgnomeprint '' '' libgnomeprintui ''.
  
 +<note important>
 +**TRABAJO EN PROGRESO**</note>
  
-**WORK IN PROGRESS** +====== Funetes ====== 
- +  * Originalmente escrito por [[wiki:user:kikinovak | Niki Kovacs]] 
-====== Sources ====== +  * Traducido por:  [[wiki:user: slackwarespanol | Victor]]  2019/08/13 19:37 (UTC) 
- +
-  * Originally written by [[wiki:user:kikinovak | Niki Kovacs]]+
  
 <!-- Please do not modify anything below, except adding new tags.--> <!-- Please do not modify anything below, except adding new tags.-->
 <!-- You must also remove the tag-word "template" below. Otherwise your page will not show up in the Table of Contents --> <!-- You must also remove the tag-word "template" below. Otherwise your page will not show up in the Table of Contents -->
 {{tag>slackware package management author_kikinovak}} {{tag>slackware package management author_kikinovak}}

En otros idiomas
QR Code
QR Code es:slackware:package_management_hands_on (generated for current page)